Batı Sitesi Mah.2307 Cad. Gersan San. Sit. No:84
Yenimahalle ANKARA

Randa IP central clock system creates a synchronized time system. The NTP server receives the correct time from the satellite with the help of GPS and distributes this time information to all secondary clocks within a facility. The master clock unit is programmed to send a frequent time signal to prevent time deviations in the secondary clocks. In this way, all the secondary clocks of a central clock system in the facility show the same time information at all times.
The system operates with PoE (Power over Ethernet), which provides both power and data over a single Ethernet cable. Using this technology, the need to connect other devices such as adapters, different cables and plugs is eliminated.
NTP Server
Randa NTP Server is a very cost-effective, accurate, Stratum-1 GPS referenced Network Time Protocol server in a compact frame. It provides accurate timing to networks and is compatible with NTPv2 (RFC 1119), NTPv3 (RFC 1305) and NTPv4 (RFC 5905). The secondary clocks are synchronized over an Ethernet network using NTP to provide a consistently accurate time display, and can use the internet-based or local NTP server. View details
Analog Slave Clock
It can be selected as single-sided or double-sided, with 30 cm or 40 cm diameter depending on the application area. It has a network (TCP/IP) feature, an ABS plastic case with IP40 protection class, and a low-voltage power supply with PoE (Power over Ethernet) technology. View details
Digital Slave Clock
Digital clocks are designed to show hours and minutes with 7-segment 4 digits; a version with a 6-digit stopwatch is also available. The standard LED color is red, and other colors are available. NTP Server, wireless RF or RS485 communication options are available. It automatically retrieves time, date and other data from the master clock, so all clocks in the system are synchronized. It has a low-voltage power supply with PoE (Power over Ethernet) technology. View details
Operating Room Stopwatch Digital Clock
It is designed with a stainless steel body considering the special needs of an operating room. It shows hour, minute and second information, and temperature and humidity values can also be displayed alternately. It integrates with the NTP protocol and has a low-voltage power supply with PoE (Power over Ethernet) technology. View details
Yenimahalle ANKARA
© 2026 Randa. All rights reserved.